What’s Vulnerable › Vulnerabilities
CVE-2020-8866
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-23 · updated 2026-06-17
- Weakness: CWE-434
Description
This vulnerability allows remote attackers to create arbitrary files on affected installations of Horde Groupware Webmail Edition 5.2.22. Authentication is required to exploit this vulnerability. The specific flaw exists within add.php. The issue results from the lack of proper validation of user-supplied data, which can allow the upload of arbitrary files. An attacker can leverage this in conjunction with other vulnerabilities to execute code in the context of the www-data user. Was ZDI-CAN-10125.
Affected products
- Debian Linux: 8.0
- Horde Groupware: 5.2.22
- Horde Form: before 2.0.20 — fixed in 2.0.20
How to fix
Upgrade to a fixed version: Horde Form 2.0.20. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2020/03/msg00036.html
- https://lists.horde.org/archives/announce/2020/001288.html
- https://www.zerodayinitiative.com/advisories/ZDI-20-275/
- https://lists.debian.org/debian-lts-announce/2020/03/msg00036.html
- https://lists.horde.org/archives/announce/2020/001288.html
- https://www.zerodayinitiative.com/advisories/ZDI-20-275/
Get alerted when CVE-2020-8866 or the next vulnerability affects your stack