What’s Vulnerable › Vulnerabilities
CVE-2020-8874
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-23 · updated 2026-06-17
- Weakness: CWE-190
Description
This vulnerability allows local attackers to escalate privileges on affected installations of Parallels Desktop 15.1.2-47123. An attacker must first obtain the ability to execute high-privileged code on the target guest system in order to exploit this vulnerability. The specific flaw exists within the xHCI component. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to escalate privileges and execute code in the context of the hypervisor. Was ZDI-CAN-10032.
Affected products
- Parallels Desktop: before 15.1.3 — fixed in 15.1.3
How to fix
Upgrade to a fixed version: Parallels Desktop 15.1.3. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-20-295/
- https://www.zerodayinitiative.com/advisories/ZDI-20-295/
Get alerted when CVE-2020-8874 or the next vulnerability affects your stack