What’s Vulnerable › Vulnerabilities
CVE-2020-8904: Arbitrary trusted memory overwrite vulnerability in Asylo
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-12 · updated 2026-06-17
- Weakness: CWE-823
Description
An arbitrary memory overwrite vulnerability in the trusted memory of Asylo exists in versions prior to 0.6.0. As the ecall_restore function fails to validate the range of the output_len pointer, an attacker can manipulate the tmp_output_len value and write to an arbitrary location in the trusted (enclave) memory. We recommend updating Asylo to version 0.6.0 or later.
Affected products
- Google LLC Asylo: before 0.6.0 — fixed in 0.6.0
How to fix
Upgrade to a fixed version: Google LLC Asylo 0.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/google/asylo/commit/e582f36ac49ee11a21d23ad6a30c333092e0a94e
- https://github.com/google/asylo/commit/e582f36ac49ee11a21d23ad6a30c333092e0a94e
Get alerted when CVE-2020-8904 or the next vulnerability affects your stack