What’s Vulnerable › Vulnerabilities

CVE-2020-8923: XSS in Dart

Description

An improper HTML sanitization in Dart versions up to and including 2.7.1 and dev versions 2.8.0-dev.16.0, allows an attacker leveraging DOM Clobbering techniques to skip the sanitization and inject custom html/javascript (XSS). Mitigation: update your Dart SDK to 2.7.2, and 2.8.0-dev.17.0 for the dev version. If you cannot update, we recommend you review the way you use the affected APIs, and pay special attention to cases where user-provided data is used to populate DOM nodes. Consider using Element.innerText or Node.text to populate DOM elements.

Affected products

How to fix

Upgrade to a fixed version: Google LLC Dart SDK 2.7.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-8923 or the next vulnerability affects your stack