What’s Vulnerable › Vulnerabilities

CVE-2020-8927: Buffer overflow in Brotli library

Description

A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.

Affected products

How to fix

Upgrade to a fixed version: Google Brotli 1.0.8; Microsoft Powershell 7.0.9, 7.1.6, 7.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-8927 or the next vulnerability affects your stack