What’s Vulnerable › Vulnerabilities
CVE-2020-8934: Site Kit by Google plugin for WordPress
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-07 · updated 2026-06-17
- Weakness: CWE-252
Description
The Site Kit by Google plugin for WordPress is vulnerable to Sensitive Information Disclosure in versions up to, and including, 1.8.0 This is due to the lack of capability checks on the admin_enqueue_scripts action which displays the connection key. This makes it possible for authenticated attackers with any level of access obtaining owner access to a site in the Google Search Console. We recommend upgrading to V1.8.1 or above.
Affected products
- Google Site Kit by Google: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: Google Site Kit by Google 1.8.1. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/google-site-kit/site-kit-by-google-171-sensitive-information-disclosure
- https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/google-site-kit/site-kit-by-google-171-sensitive-information-disclosure
Get alerted when CVE-2020-8934 or the next vulnerability affects your stack