What’s Vulnerable › Vulnerabilities
CVE-2020-9008
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Stored Cross-site scripting (XSS) vulnerability in Blackboard Learn/PeopleTool v9.1 allows users to inject arbitrary web script via the Tile widget in the People Tool profile editor.
Affected products
- Blackboard Learn: before 9.1; 9.1-q2_2017, 9.1-q2_2017_cumulative_update1, 9.1-q2_2017_cumulative_update2, 9.1-q2_2017_cumulative_update3, 9.1-q2_2017_cumulative_update4, 9.1-q2_2017_cumulative_update5 — fixed in 9.1
How to fix
Upgrade to a fixed version: Blackboard Learn 9.1. Check the vendor advisory for mitigations.
References
- https://blackboard.com
- https://github.com/kyletimmermans/blackboard-xss/blob/master/CVE-2020-9008.md
- https://blackboard.com
- https://github.com/kyletimmermans/blackboard-xss/blob/master/CVE-2020-9008.md
Get alerted when CVE-2020-9008 or the next vulnerability affects your stack