What’s Vulnerable › Vulnerabilities
CVE-2020-9223
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-29 · updated 2026-06-17
Description
There is a denial of service vulnerability in some Huawei smartphones. Due to the improper processing of received abnormal messages, remote attackers may exploit this vulnerability to cause a denial of service (DoS) on the specific module.
Affected products
- Huawei Honor 20 Pro Firmware: before 10.1.0.230\(c432e9r5p1\); before 10.1.0.231\(c10e3r3p2\); before 10.1.0.231\(c185e3r5p1\); before 10.1.0.231\(c636e3r3p1\) — fixed in 10.1.0.230\(c432e9r5p1\), 10.1.0.231\(c10e3r3p2\), 10.1.0.231\(c185e3r5p1\), 10.1.0.231\(c636e3r3p1\)
- Huawei Princeton-Al10D Firmware: before 10.1.0.168\(c00e166r4p11\) — fixed in 10.1.0.168\(c00e166r4p11\)
- Huawei Yale-L21A Firmware: before 10.1.0.230\(c432e9r5p1\); before 10.1.0.231\(c10e3r3p2\); before 10.1.0.231\(c185e2r2p1\); before 10.1.0.231\(c636e3r3p1\) — fixed in 10.1.0.230\(c432e9r5p1\), 10.1.0.231\(c10e3r3p2\), 10.1.0.231\(c185e2r2p1\), 10.1.0.231\(c636e3r3p1\)
- Huawei Yale-L61A Firmware: before 10.1.0.225\(c432e3r1p2\); before 10.1.0.226\(c10e3r1p1\) — fixed in 10.1.0.225\(c432e3r1p2\), 10.1.0.226\(c10e3r1p1\)
How to fix
Upgrade to a fixed version: Huawei Honor 20 Pro Firmware 10.1.0.230\(c432e9r5p1\), 10.1.0.231\(c10e3r3p2\), 10.1.0.231\(c185e3r5p1\), 10.1.0.231\(c636e3r3p1\); Huawei Princeton-Al10D Firmware 10.1.0.168\(c00e166r4p11\); Huawei Yale-L21A Firmware 10.1.0.230\(c432e9r5p1\), 10.1.0.231\(c10e3r3p2\), 10.1.0.231\(c185e2r2p1\), 10.1.0.231\(c636e3r3p1\); Huawei Yale-L61A Firmware 10.1.0.225\(c432e3r1p2\), 10.1.0.226\(c10e3r1p1\). Check the vendor advisory for mitigations.
References
- https://www.huawei.com/en/psirt/security-advisories/huawei-sa-20201216-03-smartphone-en
- https://www.huawei.com/en/psirt/security-advisories/huawei-sa-20201216-03-smartphone-en
Get alerted when CVE-2020-9223 or the next vulnerability affects your stack