What’s Vulnerable › Vulnerabilities

CVE-2020-9402

Description

Django 1.11 before 1.11.29, 2.2 before 2.2.11, and 3.0 before 3.0.4 allows SQL Injection if untrusted data is used as a tolerance parameter in GIS functions and aggregates on Oracle. By passing a suitably crafted tolerance to GIS functions and aggregates on Oracle, it was possible to break escaping and inject malicious SQL.

Affected products

How to fix

Upgrade to a fixed version: Django 1.11.29, 2.2.11, 3.0.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-9402 or the next vulnerability affects your stack