What’s Vulnerable › Vulnerabilities
CVE-2020-9514
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-07 · updated 2026-06-17
- Weakness: CWE-862
Description
An issue was discovered in the IMPress for IDX Broker plugin before 2.6.2 for WordPress. wrappers.php allows a logged-in user (with the Subscriber role) to permanently delete arbitrary posts and pages, create new posts with arbitrary subjects, and modify the subjects of existing posts and pages (via create_dynamic_page and delete_dynamic_page).
Affected products
- IDX Broker IMPress for IDX Broker: before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: IDX Broker IMPress for IDX Broker 2.6.2. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/idx-broker-platinum/#developers
- https://www.wordfence.com/blog/2020/03/vulnerabilities-patched-in-impress-for-idx-broker/
- https://wordpress.org/plugins/idx-broker-platinum/#developers
- https://www.wordfence.com/blog/2020/03/vulnerabilities-patched-in-impress-for-idx-broker/
Get alerted when CVE-2020-9514 or the next vulnerability affects your stack