What’s Vulnerable › Vulnerabilities
CVE-2020-9689
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-29 · updated 2026-06-17
- Weakness: CWE-22
Description
Magento versions 2.3.5-p1 and earlier, and 2.3.5-p1 and earlier have a path traversal vulnerability. Successful exploitation could lead to arbitrary code execution.
Affected products
- Adobe Magento Commerce: before 2.3.5; 2.3.5, 2.3.5-p1 — fixed in 2.3.5
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.3.5. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb20-47.html
- https://helpx.adobe.com/security/products/magento/apsb20-47.html
Get alerted when CVE-2020-9689 or the next vulnerability affects your stack