What’s Vulnerable › Vulnerabilities
CVE-2020-9708: GHSL-2020-133: Insufficient validation of user input in resolveRepositoryPath function
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-14 · updated 2026-06-17
- Weakness: CWE-24
Description
The resolveRepositoryPath function doesn't properly validate user input and a malicious user may traverse to any valid Git repository outside the repoRoot. This issue may lead to unauthorized access of private Git repositories as long as the malicious user knows or brute-forces the location of the repository.
Affected products
- Adobe Git-Server: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: Adobe Git-Server 1.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/adobe/git-server/security/advisories/GHSA-cgj4-x2hh-2x93
- https://github.com/adobe/git-server/security/advisories/GHSA-cgj4-x2hh-2x93
Get alerted when CVE-2020-9708 or the next vulnerability affects your stack