What’s Vulnerable › Vulnerabilities
CVE-2020-9760
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-23 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in WeeChat before 2.7.1 (0.3.4 to 2.7 are affected). When a new IRC message 005 is received with longer nick prefixes, a buffer overflow and possibly a crash can happen when a new mode is set for a nick.
Affected products
- Debian Linux: 8.0, 9.0
- weechat: from 0.3.4 before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: weechat 2.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/weechat/weechat/commit/40ccacb4330a64802b1f1e28ed9a6b6d3ca9197f
- https://lists.debian.org/debian-lts-announce/2020/03/msg00031.html
- https://lists.debian.org/debian-lts-announce/2021/09/msg00018.html
- https://security.gentoo.org/glsa/202003-51
- https://weechat.org/doc/security/
- https://github.com/weechat/weechat/commit/40ccacb4330a64802b1f1e28ed9a6b6d3ca9197f
- https://lists.debian.org/debian-lts-announce/2020/03/msg00031.html
- https://lists.debian.org/debian-lts-announce/2021/09/msg00018.html
- https://security.gentoo.org/glsa/202003-51
- https://weechat.org/doc/security/
Get alerted when CVE-2020-9760 or the next vulnerability affects your stack