What’s Vulnerable › Vulnerabilities
CVE-2020-9817
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-09 · updated 2026-06-17
- Weakness: CWE-276
Description
A permissions issue existed. This issue was addressed with improved permission validation. This issue is fixed in macOS Catalina 10.15.5. A malicious application may be able to gain root privileges.
Affected products
- macOS: from 10.13 before 10.13.6; from 10.14 before 10.14.6; from 10.15 before 10.15.5; 10.13.6, 10.13.6-security_update_2018-002, 10.13.6-security_update_2018-003, 10.13.6-security_update_2019-001, 10.13.6-security_update_2019-002, 10.13.6-security_update_2019-003 (+15) — fixed in 10.13.6, 10.14.6, 10.15.5
How to fix
Upgrade to a fixed version: macOS 10.13.6, 10.14.6, 10.15.5. Check the vendor advisory for mitigations.
References
- https://support.apple.com/HT211170
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-anyconnect-mac-priv-esc-VqST2nrT
- https://support.apple.com/HT211170
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-anyconnect-mac-priv-esc-VqST2nrT
Get alerted when CVE-2020-9817 or the next vulnerability affects your stack