What’s Vulnerable › Vulnerabilities
CVE-2021-0279: Contrail Cloud: Hardcoded credentials for RabbitMQ service
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-15 · updated 2026-06-17
- Weakness: CWE-798
Description
Juniper Networks Contrail Cloud (CC) releases prior to 13.6.0 have RabbitMQ service enabled by default with hardcoded credentials. The messaging services of RabbitMQ are used when coordinating operations and status information among Contrail services. An attacker with access to an administrative service for RabbitMQ (e.g. GUI), can use these hardcoded credentials to cause a Denial of Service (DoS) or have access to unspecified sensitive system information. This issue affects the Juniper Networks Contrail Cloud releases on versions prior to 13.6.0.
Affected products
- Juniper Networks Contrail Cloud: before 13.6 — fixed in 13.6
How to fix
Upgrade to a fixed version: Juniper Networks Contrail Cloud 13.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-0279 or the next vulnerability affects your stack