What’s Vulnerable › Vulnerabilities
CVE-2021-1099
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-21 · updated 2026-06-17
- Weakness: CWE-787
Description
NVIDIA vGPU software contains a vulnerability in the Virtual GPU Manager (vGPU plugin) that could allow an attacker to cause stack-based buffer overflow and put a customized ROP gadget on the stack. Such an attack may lead to information disclosure, data tampering, or denial of service. This affects vGPU version 12.x (prior to 12.3), version 11.x (prior to 11.5) and version 8.x (prior 8.8).
Affected products
- NVIDIA Virtual GPU Software: from 8.0 before 8.8; from 11.0 before 11.5; from 12.0 before 12.3 — fixed in 11.5, 12.3, 8.8
How to fix
Upgrade to a fixed version: NVIDIA Virtual GPU Software 11.5, 12.3, 8.8. Check the vendor advisory for mitigations.
References
- https://nvidia.custhelp.com/app/answers/detail/a_id/5211
- https://nvidia.custhelp.com/app/answers/detail/a_id/5211
Get alerted when CVE-2021-1099 or the next vulnerability affects your stack