What’s Vulnerable › Vulnerabilities
CVE-2021-1120
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-29 · updated 2026-06-17
- Weakness: CWE-170
Description
NVIDIA vGPU software contains a vulnerability in the Virtual GPU Manager (vGPU plugin), where a string provided by the guest OS may not be properly null terminated. The guest OS or attacker has no ability to push content to the plugin through this vulnerability, which may lead to information disclosure, data tampering, unauthorized code execution, and denial of service.
Affected products
- NVIDIA Virtual GPU Software: from 8.0 before 8.9; from 11.0 before 11.6; from 12.0 before 12.4; from 13.0 before 13.1 — fixed in 11.6, 12.4, 13.1, 8.9
How to fix
Upgrade to a fixed version: NVIDIA Virtual GPU Software 11.6, 12.4, 13.1, 8.9. Check the vendor advisory for mitigations.
References
- https://nvidia.custhelp.com/app/answers/detail/a_id/5230
- https://nvidia.custhelp.com/app/answers/detail/a_id/5230
Get alerted when CVE-2021-1120 or the next vulnerability affects your stack