What’s Vulnerable › Vulnerabilities
CVE-2021-1287: Cisco Small Business RV132W and RV134W Routers Management Interface Remote Command Execution and Denial of Service Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-18 · updated 2026-06-17
- Weakness: CWE-121
Description
A vulnerability in the web-based management interface of Cisco RV132W ADSL2+ Wireless-N VPN Routers and Cisco RV134W VDSL2 Wireless-AC VPN Routers could allow an authenticated, remote attacker to execute arbitrary code on an affected device or cause the device to restart unexpectedly. The vulnerability exists because the web-based management interface does not properly validate user-supplied input. An attacker could exploit this vulnerability by sending crafted HTTP requests to an affected device. A successful exploit could allow the attacker to execute arbitrary code as the root user on the underlying operating system or cause the device to reload, resulting in a denial of service (DoS) condition on the affected device.
Affected products
- Cisco Rv132W Firmware: before 1.0.1.15 — fixed in 1.0.1.15
- Cisco Rv134W Firmware: before 1.0.1.21 — fixed in 1.0.1.21
How to fix
Upgrade to a fixed version: Cisco Rv132W Firmware 1.0.1.15; Cisco Rv134W Firmware 1.0.1.21. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-rv-132w134w-overflow-Pptt4H2p
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-rv-132w134w-overflow-Pptt4H2p
Get alerted when CVE-2021-1287 or the next vulnerability affects your stack