What’s Vulnerable › Vulnerabilities
CVE-2021-1387: Cisco NX-OS Software IPv6 Netstack Denial of Service Vulnerability
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-24 · updated 2026-06-17
- Weakness: CWE-401
Description
A vulnerability in the network stack of Cisco NX-OS Software could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. This vulnerability exists because the software improperly releases resources when it processes certain IPv6 packets that are destined to an affected device. An attacker could exploit this vulnerability by sending multiple crafted IPv6 packets to an affected device. A successful exploit could cause the network stack to run out of available buffers, impairing operations of control plane and management plane protocols and resulting in a DoS condition. Manual intervention would be required to restore normal operations on the affected device. For more information about the impact of this vulnerability, see the Details section of this advisory.
Affected products
- Cisco NX-OS: 7.0(0)n1(1), 7.0(1)n1(1), 7.0(2)n1(1), 7.0(3)n1(1), 7.0(4)n1(1), 7.0(4)n1(1a) (+233)
- Cisco Unified Computing System (Managed): from 4.0 before 4.0\(4k\); from 4.1 before 4.1\(1e\) — fixed in 4.0\(4k\), 4.1\(1e\)
How to fix
Upgrade to a fixed version: Cisco Unified Computing System (Managed) 4.0\(4k\), 4.1\(1e\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-nxos-ipv6-netstack-edXPGV7K
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-nxos-ipv6-netstack-edXPGV7K
Get alerted when CVE-2021-1387 or the next vulnerability affects your stack