What’s Vulnerable › Vulnerabilities
CVE-2021-1388: Cisco ACI Multi-Site Orchestrator Application Services Engine Deployment Authentication Bypass Vulnerability
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-24 · updated 2026-06-17
- Weakness: CWE-269
Description
A vulnerability in an API endpoint of Cisco ACI Multi-Site Orchestrator (MSO) installed on the Application Services Engine could allow an unauthenticated, remote attacker to bypass authentication on an affected device. The vulnerability is due to improper token validation on a specific API endpoint. An attacker could exploit this vulnerability by sending a crafted request to the affected API. A successful exploit could allow the attacker to receive a token with administrator-level privileges that could be used to authenticate to the API on affected MSO and managed Cisco Application Policy Infrastructure Controller (APIC) devices.
Affected products
- Cisco ACI Multi-Site Orchestrator Software: from 3.0 before 3.0\(3m\) — fixed in 3.0\(3m\)
- Cisco Application Policy Infrastructure Controller (APIC): 3.0(3i)
How to fix
Upgrade to a fixed version: Cisco ACI Multi-Site Orchestrator Software 3.0\(3m\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-mso-authbyp-bb5GmBQv
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-mso-authbyp-bb5GmBQv
Get alerted when CVE-2021-1388 or the next vulnerability affects your stack