What’s Vulnerable › Vulnerabilities
CVE-2021-1448: Cisco Firepower Threat Defense Software Command Injection Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-29 · updated 2026-08-11
- Weakness: CWE-20
Description
A vulnerability in the CLI of Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, local attacker to execute arbitrary commands with root privileges on the underlying operating system of an affected device that is running in multi-instance mode. This vulnerability is due to insufficient validation of user-supplied command arguments. An attacker could exploit this vulnerability by submitting crafted input to the affected command. A successful exploit could allow the attacker to execute commands on the underlying operating system with root privileges.
Affected products
- Cisco Firepower Threat Defense Software: from 6.4.0 before 6.4.0.10; from 6.5.0 before 6.5.0.5; from 6.6.0 before 6.6.1 — fixed in 6.4.0.10, 6.5.0.5, 6.6.1
How to fix
Upgrade to a fixed version: Cisco Firepower Threat Defense Software 6.4.0.10, 6.5.0.5, 6.6.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ftd-cmdinj-vWY5wqZT
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ftd-cmdinj-vWY5wqZT
Get alerted when CVE-2021-1448 or the next vulnerability affects your stack