What’s Vulnerable › Vulnerabilities
CVE-2021-1449: Cisco Access Point Software Arbitrary Code Execution Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-24 · updated 2026-06-17
- Weakness: CWE-284
Description
A vulnerability in the boot logic of Cisco Access Points Software could allow an authenticated, local attacker to execute unsigned code at boot time. The vulnerability is due to an improper check that is performed by the area of code that manages system startup processes. An attacker could exploit this vulnerability by modifying a specific file that is stored on the system, which would allow the attacker to bypass existing protections. A successful exploit could allow the attacker to execute unsigned code at boot time and bypass the software image verification check part of the secure boot process of an affected device. Note: To exploit this vulnerability, the attacker would need to have access to the development shell (devshell) on the device.
Affected products
- Cisco Mobility Express 1800 Access Point Series: all versions
- Cisco Catalyst 9800 Firmware: before 16.12.5; from 17.1 before 17.3.3; from 17.4 before 17.5.1 — fixed in 16.12.5, 17.3.3, 17.5.1
- Cisco Wireless LAN Controller (WLC): before 8.5.171.0; from 8.6 before 8.10.150.0 — fixed in 8.10.150.0, 8.5.171.0
How to fix
Upgrade to a fixed version: Cisco Catalyst 9800 Firmware 16.12.5, 17.3.3, 17.5.1; Cisco Wireless LAN Controller (WLC) 8.10.150.0, 8.5.171.0. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ap-privesc-wEVfp8Ud
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ap-privesc-wEVfp8Ud
Get alerted when CVE-2021-1449 or the next vulnerability affects your stack