What’s Vulnerable › Vulnerabilities
CVE-2021-1485: Cisco IOS XR Software Command Injection Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-08 · updated 2026-06-17
- Weakness: CWE-88
Description
A vulnerability in the CLI of Cisco IOS XR Software could allow an authenticated, local attacker to inject arbitrary commands that are executed with root privileges on the underlying Linux operating system (OS) of an affected device. This vulnerability is due to insufficient input validation of commands that are supplied by the user. An attacker could exploit this vulnerability by authenticating to a device and submitting crafted input to an affected command. A successful exploit could allow the attacker to execute commands on the underlying Linux OS with root privileges.
Affected products
- Cisco IOS XR Software: before 7.3.1 — fixed in 7.3.1
How to fix
Upgrade to a fixed version: Cisco IOS XR Software 7.3.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-xr-cmdinj-vsKGherc
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-xr-cmdinj-vsKGherc
Get alerted when CVE-2021-1485 or the next vulnerability affects your stack