What’s Vulnerable › Vulnerabilities
CVE-2021-1488: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software for Firepower 1000 and 2100 Series Appliances Command Injection Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-29 · updated 2026-08-11
- Weakness: CWE-77
Description
A vulnerability in the upgrade process of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, local attacker to inject commands that could be executed with root privileges on the underlying operating system (OS). This vulnerability is due to insufficient input validation. An attacker could exploit this vulnerability by uploading a crafted upgrade package file to an affected device. A successful exploit could allow the attacker to inject commands that could be executed with root privileges on the underlying OS.
Affected products
- Cisco ASA Software: from 9.13 before 9.13.1.21; from 9.14 before 9.14.2.13; from 9.15 before 9.15.1.10 — fixed in 9.13.1.21, 9.14.2.13, 9.15.1.10
- Cisco Firepower Threat Defense Software: from 6.5.0 before 6.6.4; from 6.7.0 before 6.7.0.2 — fixed in 6.6.4, 6.7.0.2
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.13.1.21, 9.14.2.13, 9.15.1.10; Cisco Firepower Threat Defense Software 6.6.4, 6.7.0.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-cmdinj-TKyQfDcU
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-cmdinj-TKyQfDcU
Get alerted when CVE-2021-1488 or the next vulnerability affects your stack