What’s Vulnerable › Vulnerabilities
CVE-2021-1492: Duo Authentication Proxy Installer Denial of Service Vulnerability
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-25 · updated 2026-06-17
- Weakness: CWE-64
Description
The Duo Authentication Proxy installer prior to 5.2.1 did not properly validate file installation paths. This allows an attacker with local user privileges to coerce the installer to write to arbitrary privileged directories. If successful, an attacker can manipulate files used by Duo Authentication Proxy installer, cause Denial of Service (DoS) by deleting file(s), or replace system files to potentially achieve elevation of privileges. This is only exploitable during new installations, while the installer is running, and is not exploitable once installation has finished. Versions 5.2.1 of Duo Authentication Proxy installer addresses this issue.
Affected products
- Cisco Duo Authentication Proxy: before 5.2.1 — fixed in 5.2.1
How to fix
Upgrade to a fixed version: Cisco Duo Authentication Proxy 5.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-1492 or the next vulnerability affects your stack