What’s Vulnerable › Vulnerabilities
CVE-2021-1497: Cisco HyperFlex HX Installer Virtual Machine Command Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 99.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-06 · updated 2026-06-17
- Weakness: CWE-78
Description
Multiple vulnerabilities in the web-based management interface of Cisco HyperFlex HX could allow an unauthenticated, remote attacker to perform command injection attacks against an affected device. For more information about these vulnerabilities, see the Details section of this advisory.
Affected products
- Cisco HyperFlex HX-Series: before 4.0\(2e\); from 4.5 before 4.5\(2a\) — fixed in 4.0\(2e\), 4.5\(2a\)
How to fix
Upgrade to a fixed version: Cisco HyperFlex HX-Series 4.0\(2e\), 4.5\(2a\). Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162976/Cisco-HyperFlex-HX-Data-Platform-Command-Execution.html
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-hyperflex-rce-TjjNrkpR
- http://packetstormsecurity.com/files/162976/Cisco-HyperFlex-HX-Data-Platform-Command-Execution.html
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-hyperflex-rce-TjjNrkpR
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-1497
Get alerted when CVE-2021-1497 or the next vulnerability affects your stack