What’s Vulnerable › Vulnerabilities
CVE-2021-1501: Cisco Adaptive Security Appliance Software and Cisco Firepower Threat Defense Software SIP Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-29 · updated 2026-08-11
- Weakness: CWE-613
Description
A vulnerability in the SIP inspection engine of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause a crash and reload of an affected device, resulting in a denial of service (DoS) condition.The vulnerability is due to a crash that occurs during a hash lookup for a SIP pinhole connection. An attacker could exploit this vulnerability by sending crafted SIP traffic through an affected device. A successful exploit could allow the attacker to cause a crash and reload of the affected device.
Affected products
- Cisco ASA Software: from 9.8 before 9.8.4.34; from 9.9 before 9.9.2.85; from 9.10 before 9.12.4.18; from 9.13 before 9.13.1.21; from 9.14 before 9.14.2.13; from 9.15 before 9.15.1.15 — fixed in 9.12.4.18, 9.13.1.21, 9.14.2.13, 9.15.1.15, 9.8.4.34, 9.9.2.85
- Cisco Firepower Threat Defense Software: from 6.2.2 before 6.4.0.12; from 6.5.0 before 6.6.4; from 6.7.0 before 6.7.0.2 — fixed in 6.4.0.12, 6.6.4, 6.7.0.2
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.12.4.18, 9.13.1.21, 9.14.2.13, 9.15.1.15; Cisco Firepower Threat Defense Software 6.4.0.12, 6.6.4, 6.7.0.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-ftd-sipdos-GGwmMerC
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-ftd-sipdos-GGwmMerC
Get alerted when CVE-2021-1501 or the next vulnerability affects your stack