What’s Vulnerable › Vulnerabilities
CVE-2021-1504: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software Web Services VPN Denial of Service Vulnerabilities
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-29 · updated 2026-08-11
- Weakness: CWE-787
Description
Multiple vulnerabilities in Cisco Adaptive Security Appliance (ASA) Software and Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. These vulnerabilities are due to lack of proper input validation of the HTTPS request. An attacker could exploit these vulnerabilities by sending a crafted HTTPS request to an affected device. A successful exploit could allow the attacker to cause the affected device to reload, resulting in a DoS condition. Note: This vulnerability affects only specific AnyConnect and WebVPN configurations. For more information, see the Vulnerable Products section.
Affected products
- Cisco ASA Software: from 9.7 before 9.8.4.35; from 9.9 before 9.9.2.85; from 9.10 before 9.12.4.10; from 9.13 before 9.13.1.21; from 9.14 before 9.14.2.4; from 9.15 before 9.15.1.7 — fixed in 9.12.4.10, 9.13.1.21, 9.14.2.4, 9.15.1.7, 9.8.4.35, 9.9.2.85
- Cisco Firepower Threat Defense Software: from 6.5.0 before 6.6.4; from 6.7.0 before 6.7.0.1 — fixed in 6.6.4, 6.7.0.1
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.12.4.10, 9.13.1.21, 9.14.2.4, 9.15.1.7; Cisco Firepower Threat Defense Software 6.6.4, 6.7.0.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-ftd-vpn-dos-fpBcpEcD
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-ftd-vpn-dos-fpBcpEcD
Get alerted when CVE-2021-1504 or the next vulnerability affects your stack