What’s Vulnerable › Vulnerabilities
CVE-2021-1518: Cisco Firepower Device Manager On-Box Software Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-22 · updated 2026-06-17
- Weakness: CWE-94
Description
A vulnerability in the REST API of Cisco Firepower Device Manager (FDM) On-Box Software could allow an authenticated, remote attacker to execute arbitrary code on the underlying operating system of an affected device. This vulnerability is due to insufficient sanitization of user input on specific REST API commands. An attacker could exploit this vulnerability by sending a crafted HTTP request to the API subsystem of an affected device. A successful exploit could allow the attacker to execute arbitrary code on the underlying operating system. To exploit this vulnerability, an attacker would need valid low-privileged user credentials.
Affected products
- Cisco Firepower Device Manager On-Box: from 6.3.0 before 6.4.0; from 6.5.0 before 6.7.0.2 — fixed in 6.4.0, 6.7.0.2
How to fix
Upgrade to a fixed version: Cisco Firepower Device Manager On-Box 6.4.0, 6.7.0.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-fdm-rce-Rx6vVurq
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-fdm-rce-Rx6vVurq
Get alerted when CVE-2021-1518 or the next vulnerability affects your stack