What’s Vulnerable › Vulnerabilities
CVE-2021-1529: Cisco IOS XE SD-WAN Software Command Injection Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-21 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the CLI of Cisco IOS XE SD-WAN Software could allow an authenticated, local attacker to execute arbitrary commands with root privileges. The vulnerability is due to insufficient input validation by the system CLI. An attacker could exploit this vulnerability by authenticating to an affected device and submitting crafted input to the system CLI. A successful exploit could allow the attacker to execute commands on the underlying operating system with root privileges.
Affected products
- Cisco IOS XE: from 16.12 through 17.0; from 17.2 before 17.2.3; from 17.3 before 17.3.4; from 17.4 before 17.4.2; from 17.5 before 17.5.1a; 17.6.0 — fixed in 17.2.3, 17.3.4, 17.4.2, 17.5.1a
- Cisco IOS XE SD-WAN Software: from 17.2.1r
How to fix
Upgrade to a fixed version: Cisco IOS XE 17.2.3, 17.3.4, 17.4.2, 17.5.1a. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-sd-wan-rhpbE34A
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-sd-wan-rhpbE34A
Get alerted when CVE-2021-1529 or the next vulnerability affects your stack