What’s Vulnerable › Vulnerabilities
CVE-2021-1566: Cisco Email Security Appliance and Cisco Web Security Appliance Certificate Validation Vulnerability
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-16 · updated 2026-06-17
- Weakness: CWE-296
Description
A vulnerability in the Cisco Advanced Malware Protection (AMP) for Endpoints integration of Cisco AsyncOS for Cisco Email Security Appliance (ESA) and Cisco Web Security Appliance (WSA) could allow an unauthenticated, remote attacker to intercept traffic between an affected device and the AMP servers. This vulnerability is due to improper certificate validation when an affected device establishes TLS connections. A man-in-the-middle attacker could exploit this vulnerability by sending a crafted TLS packet to an affected device. A successful exploit could allow the attacker to spoof a trusted host and then extract sensitive information or alter certain API requests.
Affected products
- Cisco Asyncos: before 12.5.3-035; from 13.0 before 13.0.0-030; from 13.5 before 13.5.3-010; before 11.8.3-021; from 12.0.0 before 12.0.3-005; from 12.5.0 before 12.5.1-043 — fixed in 11.8.3-021, 12.0.3-005, 12.5.1-043, 12.5.3-035, 13.0.0-030, 13.5.3-010
- Cisco Email Security Appliance (ESA): all versions
- Cisco Web Security Appliance (WSA): all versions
How to fix
Upgrade to a fixed version: Cisco Asyncos 11.8.3-021, 12.0.3-005, 12.5.1-043, 12.5.3-035. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-esa-wsa-cert-vali-n8L97RW
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-esa-wsa-cert-vali-n8L97RW
Get alerted when CVE-2021-1566 or the next vulnerability affects your stack