What’s Vulnerable › Vulnerabilities
CVE-2021-1577: Cisco Application Policy Infrastructure Controller Arbitrary File Read and Write Vulnerability
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-25 · updated 2026-06-17
- Weakness: CWE-284
Description
A vulnerability in an API endpoint of Cisco Application Policy Infrastructure Controller (APIC) and Cisco Cloud Application Policy Infrastructure Controller (Cloud APIC) could allow an unauthenticated, remote attacker to read or write arbitrary files on an affected system. This vulnerability is due to improper access control. An attacker could exploit this vulnerability by using a specific API endpoint to upload a file to an affected device. A successful exploit could allow the attacker to read or write arbitrary files on an affected device.
Affected products
- Cisco Application Policy Infrastructure Controller (APIC): before 3.2\(10e\); from 4.0 before 4.2\(6h\); from 5.0 before 5.1\(3e\) — fixed in 3.2\(10e\), 4.2\(6h\), 5.1\(3e\)
- Cisco Cloud Application Policy Infrastructure Controller: before 3.2\(10e\); from 4.0 before 4.2\(6h\); from 5.0 before 5.1\(3e\) — fixed in 3.2\(10e\), 4.2\(6h\), 5.1\(3e\)
How to fix
Upgrade to a fixed version: Cisco Application Policy Infrastructure Controller (APIC) 3.2\(10e\), 4.2\(6h\), 5.1\(3e\); Cisco Cloud Application Policy Infrastructure Controller 3.2\(10e\), 4.2\(6h\), 5.1\(3e\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-capic-frw-Nt3RYxR2
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-capic-frw-Nt3RYxR2
Get alerted when CVE-2021-1577 or the next vulnerability affects your stack