What’s Vulnerable › Vulnerabilities
CVE-2021-1579: Cisco Application Policy Infrastructure Controller App Privilege Escalation Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-25 · updated 2026-06-17
- Weakness: CWE-250
Description
A vulnerability in an API endpoint of Cisco Application Policy Infrastructure Controller (APIC) and Cisco Cloud Application Policy Infrastructure Controller (Cloud APIC) could allow an authenticated, remote attacker with Administrator read-only credentials to elevate privileges on an affected system. This vulnerability is due to an insufficient role-based access control (RBAC). An attacker with Administrator read-only credentials could exploit this vulnerability by sending a specific API request using an app with admin write credentials. A successful exploit could allow the attacker to elevate privileges to Administrator with write privileges on the affected device.
Affected products
- Cisco Application Policy Infrastructure Controller (APIC): before 3.2\(10f\); from 4.0 before 4.2\(7l\); from 5.0 before 5.2\(2f\) — fixed in 3.2\(10f\), 4.2\(7l\), 5.2\(2f\)
- Cisco Cloud Application Policy Infrastructure Controller: before 3.2\(10f\); from 4.0 before 4.2\(7l\); from 5.0 before 5.2\(2f\) — fixed in 3.2\(10f\), 4.2\(7l\), 5.2\(2f\)
How to fix
Upgrade to a fixed version: Cisco Application Policy Infrastructure Controller (APIC) 3.2\(10f\), 4.2\(7l\), 5.2\(2f\); Cisco Cloud Application Policy Infrastructure Controller 3.2\(10f\), 4.2\(7l\), 5.2\(2f\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-capic-chvul-CKfGYBh8
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-capic-chvul-CKfGYBh8
Get alerted when CVE-2021-1579 or the next vulnerability affects your stack