What’s Vulnerable › Vulnerabilities
CVE-2021-1581: Cisco Application Policy Infrastructure Controller Command Injection and File Upload Vulnerabilities
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-25 · updated 2026-06-17
- Weakness: CWE-284
Description
Multiple vulnerabilities in the web UI and API endpoints of Cisco Application Policy Infrastructure Controller (APIC) or Cisco Cloud APIC could allow a remote attacker to perform a command injection or file upload attack on an affected system. For more information about these vulnerabilities, see the Details section of this advisory.
Affected products
- Cisco Application Policy Infrastructure Controller (APIC): before 3.2\(10f\); from 4.0 before 4.2\(7l\); from 5.0 before 5.2\(1g\) — fixed in 3.2\(10f\), 4.2\(7l\), 5.2\(1g\)
- Cisco Cloud Application Policy Infrastructure Controller: before 3.2\(10f\); from 4.0 before 4.2\(7l\); from 5.0 before 5.2\(1g\) — fixed in 3.2\(10f\), 4.2\(7l\), 5.2\(1g\)
How to fix
Upgrade to a fixed version: Cisco Application Policy Infrastructure Controller (APIC) 3.2\(10f\), 4.2\(7l\), 5.2\(1g\); Cisco Cloud Application Policy Infrastructure Controller 3.2\(10f\), 4.2\(7l\), 5.2\(1g\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-capic-mdvul-HBsJBuvW
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-capic-mdvul-HBsJBuvW
Get alerted when CVE-2021-1581 or the next vulnerability affects your stack