What’s Vulnerable › Vulnerabilities
CVE-2021-1585: Cisco Adaptive Security Device Manager Remote Code Execution Vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 20.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-08 · updated 2026-06-17
- Weakness: CWE-94
Description
A vulnerability in the Cisco Adaptive Security Device Manager (ASDM) Launcher could allow an unauthenticated, remote attacker to execute arbitrary code on a user's operating system. This vulnerability is due to a lack of proper signature verification for specific code exchanged between the ASDM and the Launcher. An attacker could exploit this vulnerability by leveraging a man-in-the-middle position on the network to intercept the traffic between the Launcher and the ASDM and then inject arbitrary code. A successful exploit could allow the attacker to execute arbitrary code on the user's operating system with the level of privileges assigned to the ASDM Launcher. A successful exploit may require the attacker to perform a social engineering attack to persuade the user to initiate communication from the Launcher to the ASDM.
Affected products
- Cisco Adaptive Security Device Manager (ASDM): before 7.18.1.152 — fixed in 7.18.1.152
How to fix
Upgrade to a fixed version: Cisco Adaptive Security Device Manager (ASDM) 7.18.1.152. Check the vendor advisory for mitigations.
References
- https://github.com/jbaines-r7/staystaystay
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asdm-rce-gqjShXW
- https://www.rapid7.com/blog/post/2022/08/11/rapid7-discovered-vulnerabilities-in-cisco-asa-asdm-and-firepower-services-software/
- https://github.com/jbaines-r7/staystaystay
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asdm-rce-gqjShXW
- https://www.rapid7.com/blog/post/2022/08/11/rapid7-discovered-vulnerabilities-in-cisco-asa-asdm-and-firepower-services-software/
Get alerted when CVE-2021-1585 or the next vulnerability affects your stack