What’s Vulnerable › Vulnerabilities
CVE-2021-1594: Cisco Identity Services Engine Privilege Escalation Vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-06 · updated 2026-06-17
- Weakness: CWE-266
Description
A vulnerability in the REST API of Cisco Identity Services Engine (ISE) could allow an unauthenticated, remote attacker to perform a command injection attack and elevate privileges to root. This vulnerability is due to insufficient input validation for specific API endpoints. An attacker in a man-in-the-middle position could exploit this vulnerability by intercepting and modifying specific internode communications from one ISE persona to another ISE persona. A successful exploit could allow the attacker to run arbitrary commands with root privileges on the underlying operating system. To exploit this vulnerability, the attacker would need to decrypt HTTPS traffic between two ISE personas that are located on separate nodes.
Affected products
- Cisco Identity Services Engine: from 2.4.0 before 2.6.0; 2.4(0.902), 2.6(0.156), 2.6.0, 2.6.0-patch1, 2.6.0-patch2, 2.6.0-patch3 (+17) — fixed in 2.6.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 2.6.0. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-priv-esc-UwqPrBM3
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-priv-esc-UwqPrBM3
Get alerted when CVE-2021-1594 or the next vulnerability affects your stack