What’s Vulnerable › Vulnerabilities
CVE-2021-1603: Cisco Identity Services Engine Stored Cross-Site Scripting Vulnerabilities
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple vulnerabilities in the web-based management interface of Cisco Identity Services Engine (ISE) could allow an authenticated, remote attacker to conduct a stored cross-site scripting (XSS) attack against a user. These vulnerabilities exist because the web-based management interface does not sufficiently validate user-supplied input. An attacker could exploit these vulnerabilities by injecting malicious code into specific pages of the interface. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. To exploit these vulnerabilities, the attacker would need valid administrative credentials.
Affected products
- Cisco Identity Services Engine: before 2.6.0; 2.6(0.999), 2.6.0, 2.6.0-patch1, 2.6.0-patch2, 2.6.0-patch3, 2.6.0-patch5 (+10) — fixed in 2.6.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 2.6.0. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-stored-xss-TWwjVPdL
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-stored-xss-TWwjVPdL
Get alerted when CVE-2021-1603 or the next vulnerability affects your stack