What’s Vulnerable › Vulnerabilities
CVE-2021-20026
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the SonicWall NSM On-Prem product allows an authenticated attacker to perform OS command injection using a crafted HTTP request. This vulnerability affects NSM On-Prem 2.2.0-R10 and earlier versions.
Affected products
- SonicWall Network Security Manager: before 2.2.0; 2.2.0, 2.2.0-r10 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: SonicWall Network Security Manager 2.2.0. Check the vendor advisory for mitigations.
References
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2021-0014
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2021-0014
Get alerted when CVE-2021-20026 or the next vulnerability affects your stack