What’s Vulnerable › Vulnerabilities
CVE-2021-20077
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-19 · updated 2026-06-17
Description
Nessus Agent versions 7.2.0 through 8.2.2 were found to inadvertently capture the IAM role security token on the local host during initial linking of the Nessus Agent when installed on an Amazon EC2 instance. This could allow a privileged attacker to obtain the token.
Affected products
- Tenable Agent: from 7.2.0 before 8.2.3 — fixed in 8.2.3
How to fix
Upgrade to a fixed version: Tenable Agent 8.2.3. Check the vendor advisory for mitigations.
References
- https://www.tenable.com/security/tns-2021-04-0
- https://www.tenable.com/security/tns-2021-04-0
- https://www.tenable.com/security/tns-2021-04-0
- https://www.tenable.com/security/tns-2021-04-0
- https://www.tenable.com/security/tns-2021-07
- https://www.tenable.com/security/tns-2021-04-0
- https://www.tenable.com/security/tns-2021-04-0
- https://www.tenable.com/security/tns-2021-04-0
- https://www.tenable.com/security/tns-2021-04-0
- https://www.tenable.com/security/tns-2021-07
Get alerted when CVE-2021-20077 or the next vulnerability affects your stack