What’s Vulnerable › Vulnerabilities
CVE-2021-20094
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-16 · updated 2026-06-17
- Weakness: CWE-125
Description
A denial of service vulnerability exists in Wibu-Systems CodeMeter versions < 7.21a. An unauthenticated remote attacker can exploit this issue to crash the CodeMeter Runtime Server.
Affected products
- Siemens Pss Cape: all versions
- Siemens Sicam 230 Firmware: all versions
- CodeMeter: before 7.21a — fixed in 7.21a
How to fix
Upgrade to a fixed version: CodeMeter 7.21a. Check the vendor advisory for mitigations.
References
- https://cdn.wibu.com/fileadmin/wibu_downloads/security_advisories/Advisory_WIBU-210423-02.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-675303.pdf
- https://us-cert.cisa.gov/ics/advisories/icsa-21-210-02
- https://www.tenable.com/security/research/tra-2021-24
- https://cdn.wibu.com/fileadmin/wibu_downloads/security_advisories/Advisory_WIBU-210423-02.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-675303.pdf
- https://us-cert.cisa.gov/ics/advisories/icsa-21-210-02
- https://www.tenable.com/security/research/tra-2021-24
Get alerted when CVE-2021-20094 or the next vulnerability affects your stack