What’s Vulnerable › Vulnerabilities

CVE-2021-2011

Description

Vulnerability in the MySQL Client product of Oracle MySQL (component: C API). Supported versions that are affected are 5.7.32 and prior and 8.0.22 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Client. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Client. CVSS 3.1 Base Score 5.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H).

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.0.35, 10.1.33, 10.2.15, 5.5.61. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-2011 or the next vulnerability affects your stack