What’s Vulnerable › Vulnerabilities
CVE-2021-20179
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-15 · updated 2026-06-17
- Weakness: CWE-863
Description
A flaw was found in pki-core. An attacker who has successfully compromised a key could use this flaw to renew the corresponding certificate over and over again, as long as it is not explicitly revoked. The highest threat from this vulnerability is to data confidentiality and integrity.
Affected products
- Dogtag PKI: before 10.5.0; from 10.5.1 before 10.8.0; from 10.8.1 before 10.9.0; from 10.9.1 before 10.10.0; from 10.10.1 before 10.11.0 — fixed in 10.10.0, 10.11.0, 10.5.0, 10.8.0, 10.9.0
- Fedoraproject Fedora: 32, 33, 34
- Red Hat Certificate System: 10.0
- Red Hat Enterprise Linux: 7.0, 8.0
How to fix
Upgrade to a fixed version: Dogtag PKI 10.10.0, 10.11.0, 10.5.0, 10.8.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1914379
- https://github.com/dogtagpki/pki/pull/3474
- https://github.com/dogtagpki/pki/pull/3475
- https://github.com/dogtagpki/pki/pull/3476
- https://github.com/dogtagpki/pki/pull/3477
- https://github.com/dogtagpki/pki/pull/3478
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DDOLFOLEIV7I4EUC3SCZBXL6E2ER7ZEN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HRE44N6P24AEDKRMWK7RPRLMCUUBRJII/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/R3I7BRAHLE2WWSY76W3CKFCF5WSSAE24/
- https://bugzilla.redhat.com/show_bug.cgi?id=1914379
- https://github.com/dogtagpki/pki/pull/3474
- https://github.com/dogtagpki/pki/pull/3475
Get alerted when CVE-2021-20179 or the next vulnerability affects your stack