What’s Vulnerable › Vulnerabilities
CVE-2021-20180
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-16 · updated 2026-06-17
- Weakness: CWE-532
Description
A flaw was found in ansible module where credentials are disclosed in the console log by default and not protected by the security feature when using the bitbucket_pipeline_variable module. This flaw allows an attacker to steal bitbucket_pipeline credentials. The highest threat from this vulnerability is to confidentiality.
Affected products
- Red Hat Ansible: before 2.9.18 — fixed in 2.9.18
How to fix
Upgrade to a fixed version: Red Hat Ansible 2.9.18. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1915808
- https://bugzilla.redhat.com/show_bug.cgi?id=1915808
Get alerted when CVE-2021-20180 or the next vulnerability affects your stack