What’s Vulnerable › Vulnerabilities
CVE-2021-20182
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-23 · updated 2026-06-17
- Weakness: CWE-552
Description
A privilege escalation flaw was found in openshift4/ose-docker-builder. The build container runs with high privileges using a chrooted environment instead of runc. If an attacker can gain access to this build container, they can potentially utilize the raw devices of the underlying node, such as the network and storage devices, to at least escalate their privileges to that of the cluster admin. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Red Hat OpenShift Container Platform 4.18: from 4.4 before 4.4.33; from 4.5 before 4.5.30; from 4.6 before 4.6.15 — fixed in 4.4.33, 4.5.30, 4.6.15
How to fix
Upgrade to a fixed version: Red Hat OpenShift Container Platform 4.18 4.4.33, 4.5.30, 4.6.15. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1915110
- https://bugzilla.redhat.com/show_bug.cgi?id=1915110
Get alerted when CVE-2021-20182 or the next vulnerability affects your stack