What’s Vulnerable › Vulnerabilities
CVE-2021-20184
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-28 · updated 2026-06-17
- Weakness: CWE-354
Description
It was found in Moodle before version 3.10.1, 3.9.4 and 3.8.7 that a insufficient capability checks in some grade related web services meant students were able to view other students grades.
Affected products
- Moodle: before 3.8.7; from 3.9.0 before 3.9.4; from 3.10.0 before 3.10.1 — fixed in 3.10.1, 3.8.7, 3.9.4
How to fix
Upgrade to a fixed version: Moodle 3.10.1, 3.8.7, 3.9.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-20184 or the next vulnerability affects your stack