What’s Vulnerable › Vulnerabilities
CVE-2021-20185
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-28 · updated 2026-06-17
- Weakness: CWE-400
Description
It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that messaging did not impose a character limit when sending messages, which could result in client-side (browser) denial of service for users receiving very large messages.
Affected products
- Moodle: from 3.5.0 before 3.5.16; from 3.8.0 before 3.8.7; from 3.9.0 before 3.9.4; 3.10.0 — fixed in 3.5.16, 3.8.7, 3.9.4
How to fix
Upgrade to a fixed version: Moodle 3.5.16, 3.8.7, 3.9.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-20185 or the next vulnerability affects your stack