What’s Vulnerable › Vulnerabilities

CVE-2021-20187

Description

It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.5.16, 3.8.7, 3.9.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-20187 or the next vulnerability affects your stack