What’s Vulnerable › Vulnerabilities
CVE-2021-20188
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-11 · updated 2026-06-17
- Weakness: CWE-863
Description
A flaw was found in podman before 1.7.0. File permissions for non-root users running in a privileged container are not correctly checked. This flaw can be abused by a low-privileged user inside the container to access any other file in the container, even if owned by the root user inside the container. It does not allow to directly escape the container, though being a privileged container means that a lot of security features are disabled when running the container. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- podman: before 1.7.0 — fixed in 1.7.0
- Red Hat Enterprise Linux: 7.0, 8.0
- Red Hat OpenShift Container Platform 4.18: 3.11
How to fix
Upgrade to a fixed version: podman 1.7.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1915734
- https://bugzilla.redhat.com/show_bug.cgi?id=1915734
Get alerted when CVE-2021-20188 or the next vulnerability affects your stack