What’s Vulnerable › Vulnerabilities
CVE-2021-20195
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-28 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw was found in keycloak in versions before 13.0.0. A Self Stored XSS attack vector escalating to a complete account takeover is possible due to user-supplied data fields not being properly encoded and Javascript code being used to process the data. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Keycloak: before 12.0.3 — fixed in 12.0.3
How to fix
Upgrade to a fixed version: Keycloak 12.0.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1919143
- https://bugzilla.redhat.com/show_bug.cgi?id=1919143
Get alerted when CVE-2021-20195 or the next vulnerability affects your stack