What’s Vulnerable › Vulnerabilities
CVE-2021-20198
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-23 · updated 2026-06-17
- Weakness: CWE-306
Description
A flaw was found in the OpenShift Installer before version v0.9.0-master.0.20210125200451-95101da940b0. During installation of OpenShift Container Platform 4 clusters, bootstrap nodes are provisioned with anonymous authentication enabled on kubelet port 10250. A remote attacker able to reach this port during installation can make unauthenticated `/exec` requests to execute arbitrary commands within running containers. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- openshift/installer: before 0.9.0-master.0.20210125200451-95101da940b0 — fixed in 0.9.0-master.0.20210125200451-95101da940b0
How to fix
Upgrade to a fixed version: openshift/installer 0.9.0-master.0.20210125200451-95101da940b0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1920764
- https://bugzilla.redhat.com/show_bug.cgi?id=1920764
Get alerted when CVE-2021-20198 or the next vulnerability affects your stack